Installing Acquia Lift Drupal for Drupal 7

Installing Acquia Lift Drupal for Drupal 7

Acquia Lift Drupal relies on several modules that you must install and enable as part of the Acquia Lift Drupal installation process. We also recommend that you install several additional modules and JavaScript libraries that extend Acquia Lift Drupal's ease of use and integration with your website.

Requirements

As you are preparing to use Acquia Lift Drupal with your website, be sure to plan for the following requirements:

Component Requirement
Drupal version Drupal 7
Modules
Keys After you purchase Acquia Lift Drupal, Acquia will email you a set of Acquia Lift keys, which are required to connect to the Acquia Lift service.
Theme Your website's Drupal theme must include the page_top region.

Recommendations

Use the following recommendations as you prepare your website for use with Acquia Lift Drupal:

Suggested administrative toolbars

There are several toolbars that you can use to make administering your website easier for you and other administrators. Based on our development work and testing, we recommend that you use one of the following toolbar modules with Acquia Lift Drupal:

Use Varnish caching

For the best performance, we encourage you to use a hosting environment that includes Varnish caching, which is natively supported by Acquia Lift Drupal.

Disable Overlay module

Although the Overlay module does not prevent Acquia Lift Drupal from working with your website, it can affect how certain information is displayed by interfering with some of the JavaScript libraries used by Acquia Lift Drupal.

Because of this, you should disable the Overlay module on your website's Modules page.

Use the jQuery Update module (if needed)

If you need to use a more current version of jQuery than what is distributed with Drupal 7, add the jQuery Update module to your website to obtain the required version of jQuery.

When you configure the jQuery Update module settings on your website, be sure to use the same version of jQuery for your admin and front sections.

Next step

After you confirm that your environment meets the requirements for Acquia Lift Drupal, you can begin the installation process.

Contact supportStill need assistance? Contact Acquia Support