---
title: "Bulk Upload Not Working Correctly"
date: "2025-02-05T22:39:49+00:00"
summary:
image:
type: "article"
url: "/acquia-cloud-platform/help/92216-bulk-upload-not-working-correctly"
id: "2f6a45f5-1221-45f9-802a-1f98e2811884"
---

### Issue

As stated within our [Modules to use with caution](/node/56176) documentation, \`dropzonejs\` which is included with Acquia Cloud Lightning provides a feature known as \`Bulk Upload\` which allows for several files to be uploaded together. Some users will experience these uploads not completing correctly, with only a portion of the files uploaded showing up after completion.

### Cause

In an environment which has multiple web servers which are being served by a single load balancer, the web server that processes the form submission may not be the web server that received the temporary file in the AJAX request, meaning that these files will not be stored correctly.

### Workaround

The simplest solution is to manually upload files through the `/media/add` interface instead. Alternately, configure Drupal's temporary files directory to use:

    /mnt/gfs/{$_ENV['AH_SITE_GROUP']}.{$_ENV['AH_SITE_ENVIRONMENT']}/tmp

Important note: Drupal system cron will take care of cleaning up the tmp folder for you. Only delete temporary files if older than temporary\_maximum\_age. Note that automatic cleanup is disabled if temporary\_maximum\_age set to 0. To check the temporary\_maximum\_age, you can use the following drush cget command:

    $ drush cget system.file --include-overridden --uri=default
    _core:
      default_config_hash: xxxxx
    allow_insecure_uploads: false
    default_scheme: public
    path: {  }
    temporary_maximum_age: 21600