---
title: "Troubleshooting \"The provided host name is not valid for this server\" error message"
date: "2025-02-06T01:25:03+00:00"
summary:
image:
type: "article"
url: "/acquia-cloud-platform/help/93681-troubleshooting-provided-host-name-not-valid-server-error-message"
id: "ce2ac562-4aae-4517-a0d4-80bb6ef227ea"
---

Issue
=====

For environments that are on the [Acquia Cloud Platform](/node/55808) infrastructure, not [Cloud Classic](/node/55808) infrastructure, when accessing the application via certain domains, pages may load with the message:

    The provided host name is not valid for this server

Cause
=====

The trusted hosts for the application was not updated after adding a new domain in the [Domains tab](/node/57277) of the Acquia Cloud UI. By default, the trusted host pattern variable, `$settings['trusted_host_patterns']`, is populated with your existing domains.  
  
This error can occur if you have set trusted host patterns manually in files such as, `settings.php` or `sites.php`.This overrides the Acquia default settings. 

  
For environments on the [Acquia Cloud Platform](/node/55808) infrastructure, there has been a known issue when adding multiple domains to soon together. This issue can cause pods in the cluster to enter a stuck state where the configurations are not updates and the pods needs manual intervention to be rotated.

Resolution
----------

If trusted host patterns have been set, either add the domain to the trusted host pattern or switch back to the default so Acquia manages the trusted hosts.   
  
If the environment is on the [Acquia Cloud Platform](/node/55808) infrastructure, and you are not using custom trusted hosts, [create a Support ticket](/service-offerings/contacting-acquia-support "Contacting Acquia Support") to confirm pod rotation. To avoid the issue in the future, wait several minutes between adding each new domain.

The issue on the platform is now resolved.