---
title: "Assessing File System disk space on Acquia Cloud Platform for usage exceeded"
date: "2025-02-06T01:26:01+00:00"
summary:
image:
type: "article"
url: "/acquia-cloud-platform/help/94116-assessing-file-system-disk-space-acquia-cloud-platform-usage-exceeded"
id: "55c9d598-52c5-44a2-8967-95a45140c532"
---

Table of contents will be added

Issue
-----

You have exceeded your file storage capacity.

**Note**

This is only for applications on the [**Acquia Cloud Platform**](/node/55808) infrastructure and not [**Cloud Classic**](/node/55808).

Resolution
----------

In order to assess your usage as to how you file storage capacity has exceeded, you need to analyze usage in the **files area**. Your website's disk usage (using SSH) in the **files area** to determine if there's an unusually large directory or file that needs to be removed. See [Enabling SSH access](https://docs.acquia.com/acquia-cloud/h/enable) and [Using SSH/Shell access](/node/57255) for additional instructions on how to use SSH.

### Finding the file storage area

To find the files area for one of your environments, you'll need to SSH into the server and change directory to `**/mnt/data**`.  
  
The `**/mnt/data**` section of the filesystem includes folders that contain your site files and some logs, such as:

*   `/shared/logs`
*   /`shared/files`
*   `/shared/files-private`
*   `/shared/sites/[drupal multisite folder name]/files`
*   `/shared/sites/[drupal multisite folder name]/files-private`
*   etc.

### Inspecting your file storage area

You can get more detailed reports of the folder sizes in your file storage area via the `**du**` Command Line Interface (CLI) utility. You can type this into an SSH session to your Acquia Cloud site:

    for nom in `find -L /shared -maxdepth 3 -user $USER -type d`; do echo -n "$nom => "; du -hs `realpath $nom` |cut -f1; done

Example output:

    /shared => 36K
    /shared/sites => 64K
    /shared/sites/database3/files-private => 4.0K
    /shared/sites/default/files => 3.4M
    /shared/sites/default/files-private => 8.0K
    /shared/php_sessions => 4.0K
    /shared/myfiles => 4.0K
    /shared/legacy-files => 4.0K
    /shared/logs => 35M
    /shared/files => 4.0K
    /shared/private-files => 8.0K
    /shared/files-private => 4.0K

You can also use the interactive utility called [`**ncdu**`](https://dev.yorhel.nl/ncdu). This utility operates like a simple directory browser, with the added plus of being an interface that provides easy-to-read information on how much space folders are taking up. Here is an example output:

    $ ncdu /shared/sites/default/files
    
    --- /shared/sites/default/files ----------
        5.1 MiB [##########] /js
        1.4 MiB [##        ] /php
        1.3 MiB [##        ] /c
      332.0 KiB [          ] /inline-images
       72.0 KiB [          ] /styles
       32.0 KiB [          ] /media-icons
       16.0 KiB [          ] /color
       12.0 KiB [          ] /languages
        8.0 KiB [          ] /pictures

Navigation is accomplished by using the arrow keys to navigate and the Enter key to select. The `/..` line will move you up one directory, but you cannot move higher than the initial directory you scanned.

The best way to understand how your volume is being filled is to check this regularly to see how folders are growing, what rate they are growing at.

Cause
-----

Many hosting companies, Acquia included, may limit the amount of space your website can use on a disk. Acquia Support frequently encounters situations where customers run out or run low on file storage space, and they need to tidy up their website's files area in order to keep their available quota from being used up.

There can be several situations where a website's files storage would reach capacity. Some reasons for this include:

*   Large or many third-party files (typically stored in `sites/default/files`, `sites/all/files`, etc.)
*   Log data (from traffic or errors) filling up your volumes' free space.