Acquia Lift Experience Builder: Troubleshooting sidebar activation

Issue

I have followed all of the procedures for setting up the Experience Builder bookmark as presented in Setting up access to the Experience Builder; yet, still having issues activating the Acquia Lift sidebar.

Resolution

  • Refresh the page: a simple step that can often solve the problem.  
  • Check to make sure the lift.js is on the page. You can check this by viewing the source of the page and searching for lift.js in the page head.

     

    View page source and look for lift.js in <head>  

  • If the Lift javascript tag is installed via the Drupal module, it is not placed on several page routes (usually internal Drupal routes) by default:

     

    Lift js tags installed by the Drupal module are not placed on some page routes by default.

     

  • In your browser, navigate to a customizable page or your website's homepage, and open the Inspector tool > Console, add the following code:

     

     window.AcquiaLiftPublicApi.activate();

    If you immediately see a pop-up window that says "Lift tools failed to authenticate - check with the Lift Team", and in the Console window it says,

    undefined

    Try the above steps in an incognito window as you may experience the on-screen error if you were already logged in to the site.

  • Check to make sure that pop-up windows are unblocked. Change your browser preferences to always allow pop-ups and refresh the page again. If blocking pop-ups is to blame, as soon as you unblock and refresh the page, you will be prompted to sign in to the Acquia Lift Profile Manager administrative interface; at which point, you will see the Experience Builder sidebar slide out from the right side of the browser window.

Cause

Experience Builder can fail to launch due to Lift JavaScript, JS tag issues, or blocked pop-up windows in the browser.

Contact supportStill need assistance? Contact Acquia Support