Information for: DEVELOPERS   PARTNERS

Modules to use with Content Hub

The following contributed modules can be used with Content Hub, either with no modifications or with some additional modules or patches. Websites with complex or circular content models may experience unexpected issues and should contact Acquia support if issues occur.

Fully supported modules

The following modules work with Content Hub without any modifications:

Modules requiring modifications

The following modules work with Content Hub, but either require additional modules or patches, or have caveats:

  • Entity Construction Kit (ECK) version 8.x–Requires that you grant anonymous users the View any [entity_type] entities permission.

  • Field Collection versions earlier than 7.x-1.0-beta12–Requires the patch from this issue.

  • File Entity (fieldable files) versions 7.x and 8.x – Files uploaded with this module before installation of Content Hub aren’t syndicated until you run cron, which updates the bundle value for uploaded files.

  • Metatag–May add a trailing slash to content, preventing content export. Learn more.

  • Paragraphs version 7.x–Requires patch. Because Content Hub supports only entities that have UUID, this module also requires the Paragraphs UUID module, which is in this sandbox.

  • Shield version 8.x–Requires both a patch from this issue on Drupal.org and adding the following configuration line to settings.php:

    $config['shield.settings']['paths'] = '/acquia-contenthub/*';
    
  • Workbench Moderation versions 7.x-1.4 and greater–Requires patch.

Unsupported modules

The following unsupported modules may cause problems when used with Content Hub:

Drupal version Unsupported modules
Drupal 7
Drupal 8