Adding the Acquia Lift Drupal modules

Installing Acquia Lift Drupal

Use the following steps to install Acquia Lift Drupal on your website:

  1. Download and extract the following modules into separate directories in your docroot/sites/all/modules/ directory:
  2. Download and extract supported versions of the following JavaScript libraries into separate directories in the docroot/sites/all/libraries directory, and then ensure that the library file names match the appropriate file and pathname in the provided examples. Unless specifically noted, you can use either the development or production versions of these libraries.

    For example, if you are using the production version of the Backbone.js library, you would ensure that it is located at /sites/all/libraries/backbone/backbone-min.js.

    Library Version Directory Example
    Backbone.js 1.x or higher /backbone /backbone/backbone.js (Development)
    /backbone/backbone-min.js (Production)
    Chosen 1.1.0 or higher /chosen /chosen/chosen.jquery.js (Development)
    /chosen/chosen.jquery.min.js (Production)
    D3.js 3.4.x or higher /d3 /d3/d3.js (Development)
    /d3/d3.min.js (Production)
    Modernizr (Development version) 2.7.1 or higher /modernizr /modernizr/modernizr.js (Development)
    Modernizr (Production version) 2.7.1 or higher /modernizr /modernizr/modernizr-min.js (Production)
    qTip 1.x only /qtip /qtip/jquery.qtip-1.0.0-rc3.j3 (Development only)
    Rickshaw 1.5.x or higher /rickshaw /rickshaw/rickshaw.js (Development)
    /rickshaw/rickshaw.min.js (Production)
    Underscore.js 1.4.4 or higher /underscore /underscore/underscore.js (Development only)

  3. If you have installed and enabled the jQuery Update module on your website and are using jQuery 1.9 or greater, for Acquia Lift Drupal to work properly you must load the jquery-migrate plugin after the jQuery script on each of your webpages.

    For example:

    <script src=""></script>
    <script src=""></script>

    For more information about the jquery-migrate plugin, or to download a development version, visit the jquery-migrate GitHub repository.

  4. Sign in to your website as an administrator, and then click Modules in the admin menu to view the Modules page.
  5. Select the following check boxes:
    • Acquia Lift
    • Acquia Lift Profiles
  6. Click Save configuration to save your module settings.
  7. In the admin bar, go to Reports > Status report, and then ensure that the report page does not display any errors for the required libraries.

    If the report displays any errors for the libraries, the Acquia Lift Drupal modules cannot locate one or more of the libraries for their use. Revisit step 2 of this procedure to ensure that your website includes all of the required libraries, and that they have the correct file and pathnames.

After you have ensured that all required modules and libraries are installed and available for use, your website has the ability to connect to the Acquia Lift service.

Next step

You can now connect the modules to the Acquia Lift Drupal service.

Sign in to vote or comment