Please wait

Loading...

Start typing in the pseudo command bar to explore the commands available.

codestudio:php-version

Change the PHP version in Code Studio

This command requires authentication via the Cloud Platform API.

Usage

acli codestudio:php-version [--gitlab-token GITLAB-TOKEN] [--gitlab-project-id GITLAB-PROJECT-ID] [--gitlab-host-name GITLAB-HOST-NAME] [--] <php-version> [<applicationUuid>]
acli codestudio:php-version 8.1 myapp
acli codestudio:php-version 8.1 abcd1234-1111-2222-3333-0e02b2c3d470
acli codestudio:php-version [<applicationAlias>]
acli codestudio:php-version myapp
acli codestudio:php-version prod:myapp
acli codestudio:php-version abcd1234-1111-2222-3333-0e02b2c3d470

Arguments

  • php-version

    Required

    The PHP version that needs to configured or updated

  • applicationUuid

    Optional

    The Cloud Platform application UUID or alias (i.e. an application name optionally prefixed with the realm)

Options

  • --gitlab-token

    Required

    The GitLab personal access token that will be used to communicate with the GitLab instance

  • --gitlab-project-id

    Required

    The project ID (an integer) of the GitLab project to configure.

  • --gitlab-host-name

    Required

    The GitLab hostname.

  • --help | -h

    Optional

    Display help for the given command. When no command is given display help for the <info>list</info> command

    Defaults to false

  • --quiet | -q

    Optional

    Do not output any message

    Defaults to false

  • --verbose | -v|-vv|-vvv

    Optional

    Increase the verbosity of messages: 1 for normal output, 2 for more verbose output and 3 for debug

    Defaults to false

  • --version | -V

    Optional

    Display this application version

    Defaults to false

  • --ansi

    Optional

    Force (or disable --no-ansi) ANSI output

  • --no-ansi

    Optional

    Negate the "--ansi" option

    Defaults to false

  • --no-interaction | -n

    Optional

    Do not ask any interactive question

    Defaults to false